Page Location: Home > Quake III Arena > Topic
lordnikon
rank 86
Posted:
Sun Jan 04, 2015 10:23 pm
quote : #1
profile : pm
Posts: 5839
Type: NTSC-U/C
It is becoming harder to run v1.16n on modern distros:

http://ubuntuforums.org/showthread.php?t=655588

I myself am trying to get it working in Debian 7 (Wheezy) 64bit:

Verifying archive integrity...tail: cannot open `+6' for reading: No such file or directory
Error in check sums 2988782453 4183380385


SFV Check on file verifies fine on local and server. I also went out to find another file online to reverify.

I will be able to use 1.16n on windows, its just interesting that we are already seeing some challenges arising in keeping this stuff going.

EDIT: I managed to break the .tar.gz file out of the .run file, extract that, and manually modify the setup scripts to get it to install. However in the end it still won't run due to 64bit incompatibilities. I have to run some seperate tests on some spare OS installs. I bet it works in a 32bit OS, and possibly in 64bit once 32bit support is added.

Some links for reading:
http://ubuntuforums.org/showthread.php?t=655588
http://askubuntu.com/questions/133389/no-such-file-or-directory-but-the-file-exists
  _________________
Sega AM2 presents Waves of Grain - "Powerslide your way through the fields to deliver the wheat crop!"
1nick9
rank 1
Posted:
Sat Sep 30, 2017 9:55 pm
quote : #2
profile : pm
Posts: 2
just wondering do u still have a copy of this tar sep from the script??? just looking to setup a linux server for hell of it and will save abit of stuff round if can provide the tar.
 
1nick9
rank 1
Posted:
Wed Oct 04, 2017 5:00 pm
quote : #3
profile : pm
Posts: 2
never mind found a copy of the tar ball. got it running on x86 modern linux distro, see this thread on dc-talk
https://www.dreamcast-talk.com/forum/viewtopic.php?f=3&t=10601&p=104050#p104050
also got a mirror of the files in your guys link setup seeing what i used and had grabbed all the files few yrs back when all was still up, when finally got my q3 server going noticed most of the guides links are down so popped em up on my dropbox besides the cfg files here https://www.dropbox.com/sh/eq13z4dthrxhvzh/AADtsGM98dtKmX63q6PQD7Wwa?dl=0 and as u can see in that thread mrneo mirrored a zip of em seeing i only got a free dropbox with not much bandwidth.
 
lordnikon
rank 86
Posted:
Fri Oct 13, 2017 11:20 am
quote : #4
profile : pm
Posts: 5839
Type: NTSC-U/C
I think I made this post, when trying to run a quake 3 server on a 64-bit distro without 32bit compatibility libs installed. So it was an error on my part at the time.
  _________________
Sega AM2 presents Waves of Grain - "Powerslide your way through the fields to deliver the wheat crop!"
k1264
rank 1
Posted:
Tue Oct 31, 2017 6:14 am
quote : #5
profile : pm
Posts: 1
Type: NTSC-J
I was trying to do the same thing on Debian 5 Lenny and after few hours of searching I actually found an official solution.

According to Makeself main page (tool that was used by id Software to make installer) we can set special environment variable for it:

Important note for certain GNU/Linux distributions: Archives created with Makeself prior to v2.1.2 were using an old syntax for the head and tail Unix commands that is being progressively obsoleted in their GNU forms. Therefore you may have problems uncompressing some of these archives. A workaround for this is to set the environment variable $_POSIX2_VERSION to enable the old syntax, i.e. :

export _POSIX2_VERSION=199209


And after that run:

sh ./linuxq3apoint-1.16n.x86.run -keep

Argument -keep is important in this case.

Probably you already fixed this error and this information will be odd, but I'll just leave it here..
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Display:   
 
View previous topic - View next topic
Page Location: Home > Quake III Arena > Topic